Invalid Floating Point Error and Region Settings

Some modules will return an invalid floating point error when running. In particular routines in ETM and Resample. Most likely this error is due to the Region Settings in Windows and the default Decimal Symbol. To resolve these errors it may be necessary to change the Decimal Symbol from a "," to a ".". 

You can alter this setting in Windows \ Control Panel \ Region \ Additional Settings.

 

Have more questions? Submit a request

3 Comments

  • 0
    Avatar
    Satyam Verma

    I have changed the decimal symbol in region tab/additional settings to '.'. But still, the software shows the same error when I try to run MLP in Land Change Modeler. Please let me know if there is another solution. 

  • 0
    Avatar
    Pablo Pardo Fernández

    I am experimenting the same problem running a MOLA process on the Spatial Decision Manager space with force contiguous allocations option checked. (If I don't check this option the process works fine)

    The process starts perfectly until the end of the first of the three steps. It is just at this moment when a new prompt appears with an Invalid Floating Point Error.

    I did a first try of the process using only raster files with real datatype. Then I did a second try usign only raster files with integer datatype. Both processes ends with the same message.

    My regional configuration is selected as English (United States). Decimal separator is the '.'

  • 0
    Avatar
    Pablo Pardo Fernández

    Additional information to my provious comment.

    If I try to assing an area requirement over 999999 pixels with Force contiguous allocation option checked the problem persists, but if the area requirement is under or equal to 999999 the process goes on.

    I am working with 6 raster datafiles.

    Is not possible to use values over 999999 pixels???

    Regards.

Please sign in to leave a comment.
Powered by Zendesk