TerrSet 18.2 Installation and License Manager Error with Windows 10: Software blocked from installation error

On some Windows 10 machines you may get an error that the software is blocked from installation. This error may occur also with opening the License Manager after installation of TerrSet 18.2. This error is due to an invalid certificate on our installation. There is a workaround and we will resolve this issue in the next patch. There is no compromise using the installer on your machines.

The workaround entails running the installer and the License Manager through the Command Prompt. To start the installation, launch the Command Prompt (CMD) as an administrator and then run the installation. Once at the Command Prompt window, change your directory to the location of the installation exe file. Then type the name of the file: i.e.,, "terrset_setup_1802", without the quotes.

After the installation, you will need to run the License Manager the same way to activate the license. Also in the Command Prompt window, change your location to the TerrSet folder in c:\Program Files (x86). Then type the name of the License Manager, i.e., "tslicmger".

Have more questions? Submit a request


  • 1

    Sorry, does not work.  Can't find a setup file in the programfiles directory.

  • 0
    kess moss humphreys

    Every time I open the Setup_TerrSet_1831 application, I can get through the InstallAware Wizard, however, I can not get past the next step. It seems to load approximately 75-80% before an error message pops up stating,

    "The service cannot be started, either because it is disabled or because it has no enabled devices associated with it


    Would you like to try again?"

    It then gives me the following options; "Yes", "No", "Cancel", "No to All", "Yes to All."

    Just wondering if this has happened to anyone else and if so how they were able to get past this issue.

  • 0
    Clark Labs
  • 0
    Romain Mejean 🌍


    I have a Windows 10 machine and I have a similar problem : my licence expired recently but I can't open the TerrSet licence manager to enter a new licence. It opens and closes instantly...

    I tried to run it by the CMD as an administrator, unsuccessfully... I tried to unistall/install TerrSet too, unsuccessfully... any ideas?

    Thanks for your help

Please sign in to leave a comment.
Powered by Zendesk